Loading...

Do you support Touch Bar?

Yes! As of December 20th, 2016, we have added the ability to use any iPad as a touch bar for your Mac.


To use the feature, you must meet the following requirements:

   * Install Duet 1.6.3.4 or later on your Mac

   * Install Duet 1.3.7 or later on iOS

   * Install macOS Sierra 10.12.2 or later on your desktop


To learn more about why we built touch bar or how it works:

Learn more about touch bar here or install the latest versions here

Still no luck? We are here to help!

Businesses often become known today through effective marketing. The marketing may be in the form of a regular news . 

Contact Us